#12 ✓resolved
Erik Dahlstrand

Ruby 1.9 incompatibility (expecting keyword_then)

Reported by Erik Dahlstrand | March 24th, 2009 @ 01:18 PM

Hi,

I'm on OS X, Ruby 1.9.1 and Rails 2.3.2. I get the following error:

=> Booting WEBrick => Rails 2.3.2 application starting on http://0.0.0.0:3000 /opt/local/lib/ruby1.9/gems/1.9.1/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in require': /opt/local/lib/ruby1.9/gems/1.9.1/gems/stffn-declarative_authorization-0.2.4/lib/declarative_authorization/obligation_scope.rb:257: syntax error, unexpected ':', expecting keyword_then or ',' or ';' or '\n' (SyntaxError) /opt/local/lib/ruby1.9/gems/1.9.1/gems/stffn-declarative_authorization-0.2.4/lib/declarative_authorization/obligation_scope.rb:281: syntax error, unexpected keyword_end, expecting $end

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

By now, decl_auth is using the GitHub issue tracker as well. Please use the one over there: http://github.com/stffn/declarative_authorization/issues

People watching this ticket

Pages